! 제품 버전을 정확하게 입력해 주세요.
제품 버전이 정확하게 기재되어 있지 않은 경우,
최신 버전을 기준으로 안내 드리므로
더욱 빠르고 명확한 안내를 위해
제품 버전을 정확하게 입력해 주세요!

Wijmo Build 5.20231.904 > 새로운 소식

본문 바로가기

핫픽스 Wijmo Build 5.20231.904

페이지 정보

작성자 GrapeCity 작성일 2023-09-15 11:07 조회 397회 댓글 0건

본문

이번 빌드는 고객 분들을 위한 개선 사항과 향상된 기능이 포함된 Wijmo 핫픽스입니다.

해당 릴리스에는 Angular 16에 대한 지원이 포함되어 있습니다.

* ViewEngine의 지원이 종료되어 이전 버전의 Wijmo는 Angular 16에서는 작동하지 않습니다. Angular 16에서 Wijmo를 사용하려면 버전 업그레이드를 진행해 주시길 바랍니다!

Angular 16 지원


 

Wijmo는 Ivy 엔진을 지원했지만, 일부 복잡한 기능(FlexGrid, CellTemplates 등)은 ViewEngine에 의존했습니다. 

당사는 이러한 기능을 Ivy만 지원하도록 리팩토링해왔으며, 이 과정에서 TypeScript 의존성을 업그레이드해야 하는 큰 변화가 있었습니다.

Wijmo의 품질이 최우선이기 때문에 변화에 대한 작업을 매우 신중하게 진행했으며, 해당 프로세스가 이행되는 긴 시간 동안 기다려주신 모든 분들께 감사 드립니다.

이제, Wijmo가 Angular 16을 완벽하게 지원합니다!

Wijmo는 FlexGrid와 Cell Templates와 같은 강력한 마크업 기능을 비롯하여, 지속적으로 Angular를 지원해왔습니다.

Wijmo가 시장에서 가장 강력한 Angular 컴포넌트와 최고의 Angular FlexGrid를 제공한다고 믿습니다.


⚠️ 주의 사항

Angular 16에서 Wijmo 버전 5.20231.904를 테스트 및 검증했기 때문에 완전한 지원을 위해서 Angular 16 버전 이상을 사용할 것을 권장드립니다.

또한, 이번 빌드 이후 모든 Wijmo 빌드는 Angular 15 이상에서만 동작합니다.

기술적으로 TS 컴파일러 옵션에서 SkipLibCheck를 true로 설정하면 Angular 14에서 Wijmo를 사용할 수 있습니다.

이는 Angular가 TypeScript 4.8 이상의 버전을 요구하기 때문입니다.

Wijmo 자체는 TypeScript 3.2와 함께 사용할 수 있지만, Wijmo의 Angular 모듈은 최신 Angular 릴리스를 지원하기 위해 TypeScript 4.8을 필요로 하고 있습니다.

참고해 주시기 바랍니다.

기타 개선 사항

  • FlexGrid Selector(선택기)에 ariaLabel 속성 추가
  • ColumnGroup 헤더의 높이/너비 설정에 대한 지원 추가
  • 향상된 CSP 지원
  • Edge 사용 시 RowDetail 컴포넌트에서 중첩 그리드 편집 개선
  • React에서 셀 템플릿에 대한 행 높이 픽스




지금 바로 Wijmo를 다운로드하여 직접 테스트해 보세요!

 
  • 페이스북으로 공유
  • 트위터로  공유
  • 링크 복사
  • 카카오톡으로 보내기
메시어스 홈페이지를 통해 제품에 대해서 더 자세히 알아 보세요!
홈페이지 바로가기
메시어스 홈페이지를 통해 제품에 대해서 더 자세히 알아 보세요!
홈페이지 바로가기
이메일 : sales-kor@mescius.com | 전화 : 1670-0583 | 경기도 과천시 과천대로 7길 33, 디테크타워 B동 1107호 메시어스(주) 대표자 : 허경명 | 사업자등록번호 : 123-84-00981 | 통신판매업신고번호 : 2013-경기안양-00331 ⓒ 2024 MESCIUS inc. All rights reserved.